PDA

View Full Version : Moss 590 failure to fire


psssniper
November 10, 2001, 07:54 PM
was at the SO. CAL. .50 cal shoot today took a break from the BFG and was shooting those little flying clay birds when all of a sudden,
CLICK
no boom!!
checked the round and no firing pin strike at all
rack another one in and
CLICK
no boom
well i'm not to smart so i tried this a few more times
nada
any help out there?? ideas?
thanks
paul

Dave McC
November 10, 2001, 08:21 PM
My guess, either the firing pin is broken or grunge in there has blocked its travel. First, remove the bolt from the weapon and if you can take it apart and clean it. Or, soak in in a good cleaner like CLP and see if that frees it up.

HTH....

psssniper
November 11, 2001, 12:00 AM
thanks mac !
will give it a go

http://www.hunting-pictures.com/members/psssniper/hat%20bfg.jpg

psssniper
November 15, 2001, 11:15 AM
upon closer inspection i found that the "little action release thingy" wasnt coming down like it should. pulled the trigger group and lo and behold there was a ROCK jammed under the "action release thingy bar". this rock looked kinda like the ones in the desert where i last shot the 590. that means it was in the trigger group for at least 125 rounds before it locked up!!

Dave McC
November 15, 2001, 04:35 PM
Glad it's straightened out. Another example of why cleaning is a good thing(G)...

psssniper
November 15, 2001, 11:50 PM
Dave
here are some pictures of the rock


http://www.hunting-pictures.com/members/psssniper/big%20rock.jpg


http://www.hunting-pictures.com/members/psssniper/rock%20in%20590.jpg

Dave McC
November 16, 2001, 06:28 AM
Yup, that'll #$%^& it up all right. Since it went over 100 rounds before glitching, we can assume the rock was migrating around the action for that time.While you've got it apart,clean it thoroughly, that rock may have brought a friend(G)...