PDA

View Full Version : M1 carbine help


Nitro96
February 3, 2013, 12:16 AM
I recently changed out a firing pin on M1 carbine and now the sucker won't eject the empty hull, anyone have any ideas what could have happened, was working fine before and I haven't made any changes or messed with anything other than firing pin

thanks in advance, any info will be appreciated

4V50 Gary
February 3, 2013, 09:11 AM
Check your ejector plunger. When pushed down, does it pop back up? If not, the channel or spring may need cleaning. If you remove the plunger, also check the ejector for burrs. The spring may also be worn.

If the case is not leaving the chamber, then it's an extraction problem. Clean beneath the extractor hook. Check the tension (does it spring back?). You may have to replace the extractor and the extractor spring. It may not even be the extractor and its spring. Make sure your chamber is clean and shiny. Dirty chambers cause the shell to stick. Check your ammunition too.

James K
February 3, 2013, 02:33 PM
" I haven't ... messed with anything other than firing pin."

That is not true. You had to have "messed with" the extractor, which holds in both the firing pin and the ejector, and with the extractor spring and plunger. I suspect you have assembled the bolt so the extractor interferes with the ejector.

Jim

Nitro96
February 3, 2013, 09:11 PM
thanks guys, it wasn't hanging in the barrel, it just wouldn't eject causing the incoming shell to lodge half way into the chamber.
I took it back down this afternoon and found a burr on the extractor, removed the burr, cleaned it up, went out and shot a few rounds and is as good as new

much thanks