View Full Version : 930 SPX problem identified, unsure on solution

November 18, 2012, 11:14 PM
I can occasionally only load 5 rounds in stead of 7. If I chamber a round, then I can continue loading all 7 (+1).

I know what's happening. The base of the first shell is catching on a gap between the magazine and magazine extension. How do I know?

When I place the forearm on the gun, there are about 5 threads showing where the mag extension screws in. Without the forearm on, if I put the mag extension on, it has 6 threads available. When I load it without the forearm on I can load 7 rounds every time.

I see lots of guys replacing the follower, magazine spring and/or the mag extension.

I don't think any of that is the problem. The problem is the forearm doesn't slide down far enough to allow all of the threads to be exposed for the mag extension to full seat itself flush with the magazine tube.

From what I've read, the Nordic mag extension may solve this problem. But I think I can solve it easier by trimming on the stock to allow it to slide down another 1/8th of an inch or so.

So what should I do? Try and trim on the stock (I'm not sure where to trim) or hope the Nordic extension solves the problem?

Other than this, the gun is excellent and I'm very happy with it.

November 22, 2012, 11:06 PM
Didn't edit my original post as I want to be complete in my testing process.

I was wrong. It was not the mag tube thread problem. I have since found I can replicate the issue with/without the forend on.

So my problem has to be the follower hanging up on the lip inside the mag extension.

Will lubing the follower and this lip do the trick or do I need to smooth the edges off of both?

November 23, 2012, 08:57 AM
There is a slight bevel, usually caused by aggressive tightening of the mag extension causing the edge to roll inward, it can happen in the factory.

Cheapest solution, use a round file and remove the bevel

Best solution: remove bevel with round file and order a Choate Hi-Viz follower

No amount of lube will solve the issue

November 24, 2012, 12:23 AM
I measured the difference between the the barrel and the magazine extension with and without the forearm attached.

I then proceeded to trim that amount off the front of the forend. I then reassembled the gun and loaded and unloaded 20 times without any problems.

I am very curious if this is the problem many people are having. Doing what I did took up any gap between the magazine tube and Choate extension and allowed the extension to thread all the way onto the magazine tube.

The forend is ever so slightly loose now though so I may have to add a large washer to tighten it up. I can move the barrel about 1/32nd of an inch perhaps. Apparently I took off just a bit too much. It wasn't pretty and it wasn't scientific. Is the pressure from the forend all that holds the barrel tightly into the receiver?

Anyways, it functions properly now loading up 7 rounds each time and the follower doesn't hang while loading or unloading.