PDA

View Full Version : Slide Stop Not Releasing on Slingshot


scsov509
May 14, 2011, 10:11 PM
Started experiencing some difficulty with the slide stop on my Smith and Wesson 908 over the last month and am not sure where to begin troubleshooting. It's engaging fine and locking the slide on the last shot, but for some reason it's started sticking intermittently where it won't release when I attempt to slingshot the slide back into battery. It's exhibiting the same problem whether I attempt to slingshot on a full magazine or even with no magazine inserted, so it's definitely not magazine related.

I should probably add that I'm not interested in debating the merits of the slingshot method vs. using the slide stop to return the slide to battery. If you want to make your case for using the slide stop then do it in another thread. I slingshot all my autoloaders, and just need some help fingering how to get this particularly one back into reliable carry service. Thanks in advance for any help you can provide. :cool:

James K
May 14, 2011, 10:49 PM
The slide coming back should cam the slide stop down out of engagement, and it should stay down. But you have to pull the slide back until it stops before letting it go forward. It sounds like you are not pulling it back far enough or you have a buffer or something preventing the slide from coming back all the way.

Jim

scsov509
May 14, 2011, 11:21 PM
I do not and will not use buffers on any of my handguns, and I always give the slide a hard pull to the rear before letting it slingshot forward. What's weird is that sometimes the slightest pull of this side rearward will release the tension enough to let the stop snap down crisply, while other times it will take 4-5 pulls to the rear before the slide cams the stop down.

The 908 has a plunger on the slide stop, so I'm wodering if it's something to do with that?

JohnKSa
May 14, 2011, 11:31 PM
I'm not familiar with the specific design of the 908, but many semi-autos have a tensioning spring or spring-loaded plunger that puts downward pressure on the slide stop so that when there's nothing pushing up on it (like the follower of an empty magazine) and it's not held in place by the friction of being in contact with the slide, it will snap down and let the slide move forward.

Assuming the 908 design uses that approach it could be that the spring has broken or has gotten weak.

Another possibility is that the slide stop is gummed up or binding somehow and that's creating enough friction that it's not moving down properly when the slide is racked.

That's not an exhaustive list of the possible issues, but those are the ones I'd check first.

scsov509
May 14, 2011, 11:58 PM
I'm not familiar with the specific design of the 908, but many semi-autos have a tensioning spring or spring-loaded plunger that puts downward pressure on the slide stop so that when there's nothing pushing up on it (like the follower of an empty magazine) and it's not held in place by the friction of being in contact with the slide, it will snap down and let the slide move forward.

It is somewhat like that design, but unlike my 1911's the spring and plunger here are actually in the slide stop itself. So maybe I'll start by looking into that slide stop to see if a replacement spring is an easy fix. Thanks.

JohnKSa
May 15, 2011, 02:09 AM
With the slide off and no magazine in place you should be able to push up on the slide stop and feel definite spring tension pushing downward. Not strong tension since not a lot of tension is required--but enough to provide definite downward force.

That will also be a good test to see if the slide stop is binding on something. It should move freely, easily, when you push upwards and should snap back down when you let go of it.

James K
May 15, 2011, 03:09 PM
I don't think that is the case with the S&W. Like the M1911, the spring/plunger only holds the slide stop in place so it is not moved by recoil. Some guns, like the BHP and the P.38 actually tension the slide stop downward, but I don't think that S&W does. You either have to push it down manually or cam it down by contact with the front of the notch in the slide.

One thing you can do easily is to remove the slide and insert a loaded magazine. It is possible that with the ammo you are using a bullet is contacting the slide stop and keeping it from moving downward. With the slide off, you can easily see if anything is interfering with the slide stop.

Jim

scsov509
May 17, 2011, 12:49 PM
I don't think that is the case with the S&W. Like the M1911, the spring/plunger only holds the slide stop in place so it is not moved by recoil. Some guns, like the BHP and the P.38 actually tension the slide stop downward, but I don't think that S&W does. You either have to push it down manually or cam it down by contact with the front of the notch in the slide.

One thing you can do easily is to remove the slide and insert a loaded magazine. It is possible that with the ammo you are using a bullet is contacting the slide stop and keeping it from moving downward. With the slide off, you can easily see if anything is interfering with the slide stop.

The plunger and spring assembly on this Smith does in fact snap the stop back down when the slide is retracted enough to relieve tension, though the cut on the slide is also angled so that when the slide is drawn back it will cam the stop down to aid if the spring doesn't work. The problem has been that neither the spring or the camming motion have been working to disengage the stop regularly as of late. I also mentioned earlier in the OP that the problem has been occurring with different magazines as well as with empty magazines, so the sticking doesn't seem to be magazine related.

That said, upon closer inspection of carry magazines last night I noticed that the nose of the top two rounds in each magazine is a little dinged up. Inserting magazines and checking for the problem I saw that the rounds are hitting the stop, so that may be part of the problem. What's strange is that I've been carrying the same Speer 124 grain Gold Dot Short Barrel round for like 10 years with no problem, and again the stop sticks even without a magazine in at all. So I'm not sure now what to think. :confused:

I started by soaking the release overnight last night in cleaning solvent to make sure there's no crud binding up that spring assembly. If that doesn't work I guess I'll see about finding a replacement stop or spring, whichever is easier to acquire. Beyond that, I don't know.