PDA

View Full Version : Loggin in over and over


Sleuth
April 8, 2011, 04:50 PM
I don't know why, but some times I want to reply to a post, and have to log in (which is OK). Then, after I write my reply I have to log in again before it will be posted. On occasion, this happens when I am already logged in to the forum.
Why ?

Jimmy10mm
April 8, 2011, 04:57 PM
Next time before you hit the return/enter key check the little box that says,"remember me". Also make sure cookies are allowed on your computer. :)

Mal H
April 8, 2011, 07:14 PM
Jimmy is correct on both counts. One other thing - do you use AOL?

Mal H
April 9, 2011, 07:00 PM
So, Sleuth, any feedback? Is it working ok now?

kinggabby
April 9, 2011, 07:11 PM
This happens with every vBulletin based forum I have been on. Just have to type faster or in my case if I think I took too long to type I Copy the text I was typing then I log back in then paste that text then I am done.

tyme
April 9, 2011, 08:44 PM
kingabby:

That's because you are not checking "remember me" when you login.

Failure to check that box means your session expires after 20 minutes (or whatever the timeout on a particular forum is configured to), so when you try to post your reply after that 20 minutes, your session has expired and the forum does not consider you logged in. Since guests can't post, it makes you log in again.

TBH, we should default that "remember me" box to checked.

Wag
April 9, 2011, 08:47 PM
Even checking the box seems to time out on me.

Strange.....

--Wag--

kinggabby
April 9, 2011, 08:57 PM
Have that checked still happens on every vBulletin based forum I am a member of.

Mal H
April 9, 2011, 09:19 PM
I'll ask both of you the same question I asked Sleuth - are you using AOL, and in particular the AOL native browser?

kinggabby
April 9, 2011, 09:27 PM
Nope as far as ISP I use cox cable and browser I use firefox 3.9.1 .

Mal H
April 9, 2011, 11:16 PM
Assuming you do allow TFL to place a cookie in your system, that is a new one on us. I don't know of any reason other than the ones given here for you to be logged out, or to appear to be logged out, that is. In reality, if you checked off "Remember me", you are still autologged off after 20 minutes of idle time, but you are also autologged in when you return. It should have been transparent to you. Maybe there is a security setting somewhere in your system that is causing it.

kinggabby
April 9, 2011, 11:20 PM
Could be ... but I have learned to deal with it .

tyme
April 10, 2011, 07:46 AM
re-logging in manually isn't what I'd call dealing with it.

Firefox 4:
Tools menu, pick Options
Privacy tab, pick "remove individual cookies"
search for thefiringline

Chrome:
From the main menu (wrench icon top right to the right of the url bar), pick Options (windows) or Preferences (linux).
On the left pane, pick "Under the Hood"
At the top, pick "Content Settings ..."
Near the top, pick "All cookies and site data"
search for thefiringline

Look at all cookies starting with "bb". The domain for each bb* cookie should be ".thefiringline.com"
If you see any cookies with domain* thefiringline.com (without a leading dot), remove them.

*Do not confuse the "Site" column in Firefox's and Chrome's listings with the domain. In FF the domain is shown near the bottom when you highlight a particular cookie -- you should see "Name:", "Content:", "Domain:" series of values on sequential lines. In Chrome, when you click on a cookie to view, you should see a similar "Name:", "Content:", "Domain:" list of values pop up below the cookie list.


Obviously, if you don't care about having to log in again, you can delete all cookies from thefiringline.com and then the cookie problem should be sorted.


A similar exercise can be applied to any forum site you're having trouble with. You only need to know what domain they set cookies for, and delete any possibly conflicting cookies with different domains. If you visit a site foo.com, the cookies that get sent are foo.com and .foo.com. If you visit a site www.foo.com, the cookies that get sent are www.foo.com and .foo.com

Sleuth
April 10, 2011, 10:30 AM
However, there must have been a glitch in the system, as I had checked "Remember me" on several prior occasions. But now it's working.

BTW, if it matters I use Wild Blue (satellite system, we live remote) and Firefox.

mrgoodwrench76
April 10, 2011, 10:35 AM
Using any anit-virus stuff? Sometimes AV software will override windows security settings automatically even after you tell windows to change it. Unless you have requested to be prompted by windows before any such change then you would not be aware.

Sleuth
April 10, 2011, 10:55 AM
When it comes to computers, I am generally "un-aware".

Wag
April 10, 2011, 11:25 AM
I think my problem is that I have script blocking but I'd rather deal with the logoffs than turn scripting back on.

--Wag--

kinggabby
April 10, 2011, 11:34 AM
So far no logging off so ... I don't know like said glitch ?

Vanya
April 10, 2011, 02:45 PM
I think my problem is that I have script blocking but I'd rather deal with the logoffs than turn scripting back on.
If you're using Firefox (and if not, why on earth...?) you want to add Noscript (https://addons.mozilla.org/en-US/firefox/addon/noscript/), from the Mozilla add-ons site. It gives you total control over script blocking, on a site by site basis.

tyme
April 11, 2011, 10:50 AM
I think my problem is that I have script blocking but I'd rather deal with the logoffs than turn scripting back on.

Turning off javascript disables much of the web. If you're worried about rogue js compromising data on important sites like banks or trading sites or even ecommerce sites like amazon, use a separate VM [1], or a separate FF profile [2], or simply use one browser (e.g. Chrome) for "safer" stuff like finances, and another VM/profile/browser (e.g. Firefox) for casual browsing. The safer browser can be loaded up with extensions, for instance -- and most of these are for Firefox -- Disconnect (chrome), Ghostery, Adblock, Noscript, Betterprivacy, HTTPS-Everywhere, Perspectives, and Leechblock (invert the rules, block everything with "*" and allow "+*.bankingsite.com" "+*.tradingsite.com" to prevent accidentally visiting less-safe sites in your "safer" firefox profile, if you don't trust noscript to do the job).

I know you think you're being prudent by disabling javascript globally, but that's a lost cause. If you're that worried about javascript, use VMs so you can use modern sites they way they're designed to be used, while isolating that from your more sensitive browsing.

Also, to echo Vanya, Noscript is great. It also does good things beyond simply blocking scripts, so it's nice to have in any FF profile even if you don't want to block javascript.

[1] Guide to setting up ubuntu inside of virtualbox: http://www.psychocats.net/ubuntu/virtualbox

[2] Guide to using Firefox profiles: http://support.mozilla.com/en-US/kb/Managing%20profiles (then modify your Firefox start menu or taskbar link or desktop link/shortcut and after the final double quote, add -no-remote -profilemanager ...that will let you easily start a new instance of firefox running a different profile even if another firefox instance is already running.