PDA

View Full Version : Mauser C96 not firing.


ghengiskhan
March 6, 2011, 08:32 PM
I have a 7.63 C96 that has but one problem, pulling the trigger does not always result in the pistol firing. Basically, the hammer doesn't drop with every pull - resulting in no boom-boom.

Does this mean I need a new trigger spring? I've taken apart the gun and it doesn't seem too complicated. But are there any other possibilities for this kind of malfunction?

Another issue I'm having is the firing pin screw is nearly stripped. Any idea on how to get it out so I can replace that as well? (I got it used, I didn't strip it.)

I think I can do it myself, but am I better off sending it to the local gunsmith? I'm a pretty competent hands-on kind of person so I am confident in my own abilities.

James K
March 6, 2011, 10:11 PM
First, what firing pin screw? There is no such animal in the C96.

Second, in worn guns it is common for the trigger to slip off the sear without tripping it. The only solution is a new part, but which that would be I can't tell from here.

Jim

ghengiskhan
March 6, 2011, 10:46 PM
1) I suppose "screw" was the incorrect term. But the firing pin has a slot in it which one can use to remove the entire firing pin. So there's no actual screw in the firing pin, just the slot in the pin itself has been completely worn down.

2) The only part the trigger pushes on is the little spring/lever. I can't think of anything else in the firearm that could make it malfunction. The mainspring and rocker plunger combo certainly couldn't, right?

mpmax
March 7, 2011, 11:08 PM
Check out The Broom Closet; aka 'The Gun Rack' in Brooksville, FL.. This guy has been rebuilding c96's for decades. He'll fix your issues.
David, The Broom-closet
A Division of The Gun Rack
9184 NW CR 225
Starke, Florida 32091

Ph:904-964-5033