PDA

View Full Version : Mossberg 500 pump feeding problem


HAMMER1DOWN
May 28, 2009, 08:19 PM
Hi ya'll. I have a Mossy 500 pump that i got for christmas a couple years and pry 2000 shotshells ago, but now it doesn't like to feed a round from the magazine tube. You really have to rack it hard to get one to eject out of the tube.. It used to work flawlessly and I talk that particular shotgun up to no end but now i kinda am doubting my words. Is there an easy fix to this problem or does it need to take a trip to the gun doc?
Thanks
HAMMER1

dalegribble
May 28, 2009, 09:14 PM
i've had 1 for 20 years , my kids each have 1 with no problems. i can't think why the action would be hard unless it needs to be cleaned. hose her down with some cleaning spray and blow out all the gunk unless you are short stroking it or something? 2000 rds shouldn't even be broken in yet let alone be broken. but sometimes chit happens so anything is possible.

Barber2678
May 28, 2009, 09:38 PM
I thought Mossberg's were disposable. You know, at the end of the year throw the old one away and buy a new one. Aren't they like $175? :D

Old Guard Dog
May 29, 2009, 08:47 AM
Sounds like a dirty mag tube, and or spring. The mag tube needs to be unscrewed from the receover, and the tube, spring and follower cleaned up, or replaced. Wolff springs and Brownell followers in aluminum or stainless steel can't be beat.

skydiver3346
May 29, 2009, 10:15 AM
Thats a good one, thats why I own two Rem. 870's...

HAMMER1DOWN
May 30, 2009, 10:39 AM
Thanks i'll try givin her a once over and tear her down and clean and get back to you all