PDA

View Full Version : Ruger Mark 3 Hunter issue


chansen49
February 26, 2009, 06:54 PM
I just bought a mark 3 hunter, Ive shot about 500 rounds through it, about 5 or 6 different types of amm, about once a clip.. The rim of the spent shell gets caught between the new bullet coming out of the magazine and the guide rod?<-- that guides the slide?.. Same way every time.. I took it to Jim Hoag to see what he thought.. He said send it back.. :( Bummer, I dont want to be w/out for 7 weeks.. It costs to much to shoot everything else.. Thats why I wanted the plinker.. Keep my trigger finger warm..

Anyway, I thought Id vent and maybe see if anyone has seen or heard of any similar issue with these guns..

End of vent..

Thanks

Chris

Unclenick
February 27, 2009, 11:18 AM
It's jamming between the feeding round and the recoil spring guide? Odd one. It sounds like the case isn't being pulled back against the ejector properly to get it out of the gun. I would look at the ejector nose and position. Also look to see the extractor hook tip looks sharp and normal.

thebiggie32
February 27, 2009, 12:31 PM
I had the samw problem with my Mark III Target pistol. I think it was the ammo I was using. I never had any do it when i was using CCI but the Federal ammo did it just about every time I used on specific magazine. I tried the Remington bulk ammo and it didn't do it. I noticed on the cartridge that wasn't ejecting properly didn't have much of a lip for the extractor mechanism to grab onto. So I guess it was the ammo. Since i switched I haven't had any problems. Good luck with yours.