PDA

View Full Version : Empty shells doesn't eject from remington 870


frankverrees
July 10, 2008, 03:58 PM
Hello,

I have a problem with my 870.
When i shoot and pump, the empty shell doesn't ejects.
Or shell comes out very slowly with now power.
With full shells there is no problem, they ejects nicely.
What is happening?

Anyone can help me?

Thank you

Bill DeShivs
July 10, 2008, 04:33 PM
Are you shooting 3" shells in a 2-3/4" gun?

Scattergun Bob
July 10, 2008, 06:52 PM
Hi Frank,

Hard to tell with what info you have given. How about some more.

type manufacture and length of shell

serial # of 870 is it a wingmaster or express.

Is there a M in front of the serial #

Reach inside of the receiver and wiggle the ejector up and down is it loose?

Does the extractor drop the shell BEFORE it reaches the ejector?

With some of these questions answered, we might be able to help. If the ejector is at fault that would be bad news, other than one effective fix, the gun will probably need to be returned to the factory.

Look forward to reading your response, Good Luck & Be Safe

BHP9
July 11, 2008, 08:21 AM
Are you using cheap Wally World ammo?

The stuff with the aluminium or tin base.

frankverrees
July 11, 2008, 04:09 PM
I use the Marine magnum 870.
The shells I use are Federal, RC, Remington, Winchester 2 3/4" and 3"
The serial number is : D958702M
The ejector is in my eyes OK.
Extractor also I think?
What is the problem?

hogdogs
July 11, 2008, 05:11 PM
I reckon you have cleaned the chamber super duper good with the barrel off?
From there I leave this up to owners of such guns.
Brent