PDA

View Full Version : Winchester 97 extractor problem, please help


Cooter85
June 21, 2008, 01:41 PM
First I would like to say that I am not an expert on this situation, that's why I am posting this here, to talk to the experts. ;)

My Winchester 97 (solid frame, I think) does not eject the shell when I pump it. I think that this part (showed in the attached pictures) is the problem. It looks as if it was broken off. So my first question is will replacing this part fix the problem?
I believe I found the right part on e-gunparts.com, called an 'ejector spring.' The picture looks like the right part, but I am confused as to why it's called a spring. So is this a typo from the website, or is that what I need to order?
http://www.e-gunparts.com/product.asp?chrProductSKU=248370A&MC=

Thank you for your help, and please forgive my ignorance. :D

Slopemeno
June 21, 2008, 01:57 PM
You nailed it. Replace it and you should be good to go.

sesquipedalian101
June 22, 2008, 12:08 AM
eBay carries various firearm manuals from time to time; you might want to invest in a repair manual for your '97 -- a gun like that deserves a TLC guide.

-101-

Cooter85
June 22, 2008, 02:33 PM
Thanks guys, I'll get her fixed soon. I love this old shotgun, I'm excited to take her on another date to the shootin range again. :D

Hawg Haggen
June 22, 2008, 02:39 PM
Maybe this will help. http://marauder.homestead.com/files/model97down.html

Joat
June 24, 2008, 09:04 AM
Yep that would be the problem. The ejector springs (new manufacture) are also available from Brownell's.

Joat