PDA

View Full Version : Benelli problems


billindenver
January 21, 2008, 10:38 AM
Well, I have a benelli M1 super 90 that I bought new a couple of months ago. Took it trap and skeet shooting many times to break it in and get used to it and she worked like a champ. Took it duck hunting a few times and no problems, love that gun. Last weekend I twice had the second round not go boom...click when I pulled the trigger...no impact on the primer. So I took the bolt out, cleaned the firing pin, bolt, carrier etc real well and considered it good.

This Saturday she worked great all morning on a goose/duck hunt (maybe a box of shells through it) and then started failing to feed the second round. The first would fire, eject and the next would be sitting on the feed ramp but the ramp would not push it up unless I jiggled the bolt back and forth. Ok, sounded like dirt in there somewhere to me so Saturday night I tore her down again, this time removing the trigger mechanism and the stock. What looked like machining debris from manufacture was all over the recoil spring that goes into the stock behind the bolt. Ok, so I spent a couple hours cleaning the entire area and put her back together.

Sunday morning we are back at our favorite duck hole and as the sun comes up we have one of those mornings where 1000 ducks fly directly over your head at 20 yards up in groups of 5 or 6. Lasted about 45 minutes and sounded like warfare from the shotguns going off. I spent 10 of that trying to get my benelli to fire even one round, and the other 20 running back to the truck for my citori and running back. When I pulled the trigger I would get a click, but no boom...cycle the round out to reset the hammer and click, cycle....click, cycle...click, cycle....BOOM. Repeat repeat. Would fire maybe one in 6.

I'm not saying it is impossible that I've not cleaned it well enough or something along those lines but I seriously cleaned the hell out of it to no avail. Has anyone ever seen a benelli do this? Very strange. I would sure hate to use a nice citori for waterfowl but at this point I'm nearly there.

Tbag
January 21, 2008, 05:11 PM
Any chance you have bad ammo as part of the problem? I would be sending that into customer service asap. If you tell them that you need right back to go hunting they may turn it around for you quickly, well, Browning did that for me. I had mine back within 4 days.

BigJimP
January 24, 2008, 01:08 PM
It sounds to me like you have a shell problem - before I do anything to the gun, I would try some different ammo / but if it ran fine at the trap and skeet range - I think that tells you its a shell problem.

I don't what you were shooting but try some major brand ammo like Remington or Winchester / and take it a range and test fire a box or two.

You do have to keep these guns, and all guns, clean and lubed - but the Benelli system is by far the cleanest shooting semi-auto on the market. I have a Benelli Super Sport - in 12 and 20ga and neither one of them have ever let me down on doves, quail or in sporting, trap or skeet. But I don't think the problem you are having is a gun problem.

yomama
January 25, 2008, 01:53 PM
I'm with the ammo to.

Just went hunting, and one out of two winchester shells wouldn't fire. When we inspected the primers, they were not even dented. The other cheap loads were going off no problem. Inspected them, and saw nice primer strikes.

It was only the ammo, the winchester had very hard primers.

castnblast
January 25, 2008, 02:26 PM
on the ejection, (don't know about the misfires) were you at an odd angle where you moved a lot with the recoil? remember it's recoil operated, and too much movement could screw up the feed, kind of like limp wristing a .45acp.