PDA

View Full Version : Old Sears Model 66 semi-auto 12ga won't eject.


sorny
October 25, 2007, 08:37 AM
I bought a Sears Model 66 12 gauge semi-auto shotgun a year or two ago and as long as I've had it I can't actually get it to eject shells properly. It holds 4 shells in the magazine tube and usually what happens is after a round or two it will jam and the empty shell will still be in the barrel and the next shell from the magazine will be jammed in behind it. I thought at first it might've been a problem with loading the new shells in but when I fire it with one round at a time (only the one in the barrel) it doesn't eject it either or once in a while I think it gets stuck halfway like the tip of the old shell might be sticking out the ejection port.

I've cleaned it numerous times and I assume it's the ejector but I don't really know what to check and how to check it. I only paid $75 for the gun and the barrel and the stock have been cut (legally) so its not worth just dropping it off to a gunsmith and waiting for an expensive bill to come in for it.

Dfariswheel
October 25, 2007, 02:38 PM
The Sears Model 66 is actually the J.C. Higgins Model 66.

Gun Parts Corporation carries parts for them:

http://www.e-gunparts.com/products.asp?chrMasterModel=0780z66&MC=

I would suggest a new extractor and spring, and a new ejector and spring.

Just as a check, you have tried a different brand/type of ammo?
Some of the newer inexpensive shells are giving extraction problems.

Also, buy a chamber cleaning brush and scrub the chamber out. Modern shells are bad about building up fouling and plastic in the chamber and making problems.