PDA

View Full Version : Colt Defender


auberg
August 27, 2006, 02:18 PM
Okay, I need you guys, to give me an idea what may be going on with my Defender. I had a new trigger and a magwell installed on it about a week ago. I only got the chance to take it to the range today, when I loaded it and pulled the trigger, nothing happened, no bang. I manually cycled the round out and the next one in, same thing, even tried a different ammo, same result. I inspected each shell, there was only a scuff on the primer. No dimple. Here is my question, would the trigger job have anything to do with how hard or far the firing pin would hit the primer?

Thanks

James K
August 27, 2006, 07:35 PM
AFAIK, that gun has the Series 80 firing pin block. If so, it sounds like the trigger has been set up so it trips the sear without coming back far enough to raise the firing pin block in the slide. I can't tell you how to fix it without seeing the gun, but you say you "had" a new trigger installed, which sounds like you took it to a gunsmith. Take it back and have him do the job right.

Jim

auberg
August 27, 2006, 07:56 PM
Thank you Jim, I had planned to take it back to him, to straighten it out, but I wanted to have an idea what the real problem was.

I did field strip it, and figured out it had to do with the block, but didn't figure it out completely.

Thanks again

Frank

ScottsGT
September 1, 2006, 11:07 AM
Is the trigger one with an adjustment screw that limits travel? Might need to give it a few turns out if so.

auberg
September 1, 2006, 05:11 PM
actually it is, but it is back in the hands of the smith. They are going to take care of it. I just was curious about what the problem could have been.

Thanks though.

Frank