PDA

View Full Version : SA TRP Problem


larryw
May 13, 2002, 03:03 PM
I have a fairly new TRP and am having problems with it failing to load properly. At first I thought the problem was with the Wilson 47D mags I purchased as the last round of the mag would fail to go into battery. So I purchased some Chip McCormick Shooting Star mags and both the first and last rounds fail to go into battery. To complicate things, when shooting +P ammo, the last round fails to lock the slide back. The two factory mags exhibit similar problems, although not nearly as frequently.

So, looking at the failures, it appears like the round is getting hung up as it slides up the breech face, perhaps near the extractor.

Suggestions on how to clear this up short of sending it to Springfield would be appreciated.

thanks,
LW

M1911
May 13, 2002, 08:25 PM
Is the breech face rough? Perhaps the extractor tension is too tight? Either way, I'd send it back to Springfield.

M1911

George Stringer
May 14, 2002, 07:21 AM
Larry, you can go to http://www.m1911.org/m1911dt.htm and on the left side of the page you'll find Techincal Issues. In there is an article by Bill Wilson on tuning your extractor. You might take a look at it and see if it's something you'd rather try than sending the gun back. Other than that I'd send it back to the maker. George

larryw
May 14, 2002, 10:26 AM
Thanks guys.

Yes, the breech face is rough: I see brass discoloration in the machine grooves. I'd already tried tweaking the extractor.

Any suggestions on how to proceed if I want to polish the breech face myself? Tools and techniques? (I'm a DIY kinda person). I may try this before I send it back (although I'll first call SA to make sure this doesn't cause warranty problems). Teddy Jacobsen did this to a couple of my guns and they sure feed nice.

M1911
May 14, 2002, 12:04 PM
I just used some 500 or 600 grit sand paper, some oil, and a thin, flat stick. Remove the firing pin and extractor before doing so. Work slowly, stop frequently, and inspect carefully.

M1911

larryw
May 14, 2002, 01:53 PM
I think I'll try polishing the face. I just returned from the range and the problem seems to be working its way out so I'll speed things up a bit. Out of 350 rounds shot, I had 5 jams and one of them looked to be an out-of-spec round: reload didn't seat the bullet all the way, OAL was 1.267, granted, that's within spec for a 230gr FMJ round, but all my reloads are 1.250.

Thanks for all the help!

LW